Back
Degraded

Citrix Services Degraded
Started 24 Feb at 09:38am GMT, resolved 24 Feb at 09:49am GMT.
Citrix Desktop-as-a-Service
Resolved
The issue with Citrix has now been resolved. Apologies for the interruption.
Posted 24 Feb at 09:49am GMT.

Created
Users have reported not being able to connect to Citrix with an error about resource not available. We are investigating this now.
Posted 24 Feb at 09:38am GMT.