Back
Downtime

Citrix Services Degraded
Started 10 Jan at 12:05pm GMT, resolved 10 Jan at 12:45pm GMT.
Citrix Desktop-as-a-Service
Resolved
We believe the servers are back to normal now. We will monitor closely and follow up with an incident report once we know more about the cause.
Thanks for your patience.
Posted 10 Jan at 12:45pm GMT.

Created
We are aware that some users may be experiencing issues connecting to their hosted and Citrix desktops. Our engineers are actively investigating this as a Priority 1 (P1) incident.
We will provide updates here as soon as more information becomes available. Thank you for your patience and understanding.
Posted 10 Jan at 12:05pm GMT.